Error message during single image processing

View previous topic View next topic Go down

Error message during single image processing

Post  jensr on Fri Sep 04, 2009 11:22 am

Hi Marc et al.

We're getting an erorr during the processing of our first image.
Initially we had problems with memory allocation, so I have switched to the JRockIt java engine instead, and it seemed to have helped in that the processing actually starts, whereas before it would fail almost instantly before (processing large frame 2400 dpi images).
Anyway, to test things out, i ran single image conversion, which worked, and then set it to run the processing of that image. This ran fine for about 2 hours, but left overnight, and error occurred somewhere, approximately halfway down the iamge when a macro error pops up:

Index (255) out of 0-254 range in line 609.

while (hh < 256) { dat = Histcum [hh <]>/sumg;

After ok'ing the error, Zooprocess pops up the normal end to processing message box, but the _meas file is empty.

Here's a dump of the log file regarding processing and particle analysis:

Code:
[Process]
ConfigFile= process_install_both_config.txt
Version= 6.01_2009/02/27_Picheral_CNRS
Multiple_image_process= NO
Date=  20090903_1411
 
Image_Process
vis1_file= PROCESS
Date=  20090903_1411
stn-2000-05-29-497-a1_1
ConfigDataImg= +last+no+created_20090707_1441+100+0+4+2400+0.9+0+150+2+0.025+0.25+2.0+20.0+0+neutral+243+174+1+1+1+pixel+100.0+0.3+100+1.0+0.3383+4.2852+16.0+8+4.0+1.3+0.05+0.1+10+both
Image_process= Zooscan_1asep
Version= 6.10_Picheral_CNRS
Image_path=  H:\\Zooscan_stn_mr350
Image=  stn-2000-05-29-497-a1_1.tif
Frame=  _1
Raw_image_depth=  8 bits
Raw_image_size=  365051090
Raw_Image_BackUp_as_ZIP= NO
Final_Image= 8bits
Corrected_width=  24272
Corrected_heigth=  15040
Grey_Level_Adjustement= YES
Resolution=  2400
ODxminref=  23979
ODyminref=  7367
ODxdimref=  60
ODydimref=  600
OD_measured=  77
Max-min_grey_difference_in_OD=  19
STD=  2.1085
OD_correction= NO
Background_correct_using=  20090708_0932_background_large_manual.tif
Image_treatment= natural
Right_side= Automatic_supress
Right_side_Limit=  23273
Transparent_frame= CLEAR
Greytaux= 0.9
Greylimitright= 168
Right_limit= 23162
Greylimitrleft= 200
Left_limit= 84
Greylimittop= 171
Upper_limit= 172
Greylimitbottom= 147
Bottom_limit= 14678
Vis_image_save= YES
 
Particules_Process
Particule_Process_Date=  20090903_1417
Version= 5.00_2006/12/29_Picheral_CNRS
ConfigDataP= +last+no+created_20090707_1441+100+0+4+2400+0.9+0+150+2+0.025+0.25+2.0+20.0+0+neutral+243+174+1+1+1+pixel+100.0+0.3+100+1.0+0.3383+4.2852+16.0+8+4.0+1.3+0.05+0.1+10+both
Resolution=  2400
Calibration=  created_20090707_1441
Threshold=  243
PixSize=  0.0106
MinSize=  0.3
MaxSize=  100
Method=  default [ 0.3000  -  100 ]
Measures_unit=  pixel
Min_Area=  631
Max_Area=  70120652
Separation_Mask= UNUSED
Particle_Analysis= YES
Analysis_Method= from_thumbnail_images_fractalA_skeleton_Slope_Histcum_Mg5_Complexity_Symetry
Particle Analysis ABORTED
Analysed_Objects=  0
TAG= NO
Results=  SAVED
Date=  20090904_0906


Last edited by jensr on Fri Sep 04, 2009 1:16 pm; edited 1 time in total (Reason for editing : fixed typo's)
avatar
jensr

Posts : 8
Join date : 2008-09-26
Age : 43
Location : Marine Scotland Science, Aberdeen, UK

View user profile http://zooimage.overchord.net

Back to top Go down

Single Image processing error

Post  picheral on Sat Sep 12, 2009 5:40 pm

Dear Jens,
Soory to answer so late... This error is probably not a single process image error but an error related to this image. Did you try processing it in batch mode ?
As this image is the first to work with on your system, there might be some adjustements to do. So, if you cannot process it, please email me. I will give you a password to load the image on my FTP and I will test it on my side.
Regards
Marc P.

picheral

Posts : 60
Join date : 2008-05-02

View user profile http://www.zooscan.com

Back to top Go down

Re: Error message during single image processing

Post  jensr on Mon Sep 14, 2009 3:03 pm

Hi Marc

No worries - I will try batch mode first. I was just testing it out after trying the alternative java engine and started with a single image. I'll let you know if there are any problems in batch mode.
Cheers,
Jens
avatar
jensr

Posts : 8
Join date : 2008-09-26
Age : 43
Location : Marine Scotland Science, Aberdeen, UK

View user profile http://zooimage.overchord.net

Back to top Go down

Re: Error message during single image processing

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum