Load Identifications Macro Error

View previous topic View next topic Go down

Load Identifications Macro Error

Post  Siphs on Tue Nov 06, 2012 1:57 am


Hi,

Every time I try to "Load Identifications from sorted vignettes", I get the Macro Error:
index (1) out of 0-0 range in line 321
datafile = listaff [h <]>;

I am running Zooprocess ver. 7.12, and have placed the Analysis.txt file in the Pid_results folder. The sorted images are in a *_to_validate folder in the "Sorted_vignettes" folder.
I extracted the images using ImageJ, and then sorted them with XnView.

Do I need to move certain files to special folders for the "Load" function to work?

Any suggestions would be welcome!

Siphs

Posts : 4
Join date : 2012-11-06

View user profile

Back to top Go down

Re: Load Identifications Macro Error

Post  Boris on Thu Nov 08, 2012 5:47 pm

Hi,

try this:

In your zooscan_config folder check if there is a file named zooscan_indet....

if not,
create a new project with a recent macro, over 7.07,
in the zooscan_config folder you should find this file (zooscan_ident_list)

copy this file in your current zooscan_config folder
and try again the load command

that's worked for me


Boris

Posts : 5
Join date : 2009-03-25

View user profile

Back to top Go down

Re: Load Identifications Macro Error

Post  Siphs on Fri Nov 09, 2012 9:57 am


Still not working.
I have a "zooscan_liste_ident" file, which I guess is the french equivalent to what you mention. I also tried replacing it with the file from a new project.

Is it perhaps because I modified some folder names while validating the images in XnView?

Siphs

Posts : 4
Join date : 2012-11-06

View user profile

Back to top Go down

Re: Load Identifications Macro Error

Post  Boris on Fri Nov 09, 2012 11:57 am

what folders have you modified the name?

Boris

Posts : 5
Join date : 2009-03-25

View user profile

Back to top Go down

Re: Load Identifications Macro Error

Post  Siphs on Mon Nov 12, 2012 10:13 am


My learning set, and therefore the folders I get by automatic identification using ZooProcess are not the same as those listed in the "zooscan_ident_list". I modified the learning set folder names in ImageJ "learning" window.
Is there a way to modify the list? I tried typing in the new folder names (e.g. "Nauplius"), but get the same error.

I'm sorry, I don't understand much about how Zooprocess works yet....

Siphs

Posts : 4
Join date : 2012-11-06

View user profile

Back to top Go down

Re: Load Identifications Macro Error

Post  Boris on Mon Nov 12, 2012 12:51 pm

you mix up zooprocess with plankton identifier,

I don't think it's a good idea to replace the name of the folder, ZooProcess is a little bit sensitive to any operation out of plan
try a test with a new project without change the name and you will see if you find the same problem
good luck

Boris

Posts : 5
Join date : 2009-03-25

View user profile

Back to top Go down

Re: Load Identifications Macro Error

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum